Project

General

Profile

[Solved] newbie FAMNoExists

Added by signmeuptoo about 2 months ago

Hi, my OS is Mint KDE 18.2 Sonya

I've never set up lighttpd or used it before. I used my OS's gui package manager to install it (was that wrong?)

Using your most basic tutorial and making the lighttpd.conf file in my home directory as user, I then tried to run that first line and this is what I got:

lighttpd -t -f lighttpd.conf
lighttpd: symbol lookup error: lighttpd: undefined symbol: FAMNoExists

Your tutorial doesn't say where to put the .conf file, that is another question.


Replies (10)

RE: newbie FAMNoExists - Added by citaylor about 2 months ago

The FAMNoExists is a distro issue:

https://bugs.launchpad.net/ubuntu/+source/lighttpd/+bug/1453463

Seems to deal with the issue on Ubuntu, and I would suggest its probably a similar issue on Mint.

RE: newbie FAMNoExists - Added by signmeuptoo about 2 months ago

Yes, installing that package did work, but now when I point my browser to http://127.0.0.1:3000/ I get 404 not found.

RE: newbie FAMNoExists - Added by signmeuptoo about 2 months ago

NO! I was wrong, I get this when I try to go to 127.0.0.1:3000/

403 - Forbidden

I tried with the lighttpd.conf file that installed with my software manager setup and set the port to 3000 and the same result.

I am wondering if there is a step I am missing since I installed with my GUI software manager in Mint KDE 18.2 rather doing it via source code and compile-install?

RE: newbie FAMNoExists - Added by gstrauss about 2 months ago

Have you tried your favorite search engine for "lighttpd" and "Mint"?

There is obviously a misunderstanding between you and the lighttpd config shipped in the Mint distro package for lighttpd.

RE: newbie FAMNoExists - Added by signmeuptoo about 2 months ago

No luck finding answers with that search idea, but here is a question, in the configuration file, do I literally use this line, or sub something:

server.document-root = "/var/www/servers/www.example.org/pages/"

Because I have no servers directory under /var/www/ and does that install by default with your site's install procedure perhaps?

RE: newbie FAMNoExists - Added by signmeuptoo about 2 months ago

Also, I did try your site's basic config also, the first one on the tutorial.

RE: newbie FAMNoExists - Added by signmeuptoo about 2 months ago

This piece of instruction is where I wonder what gives:

You Are Here: Home → Linux → How To's → Ubuntu → How to Install Lighttpd With PHP5 (FastCGI) And MySQL On Linux Mint 12 / Ubuntu 11.10
How to Install Lighttpd With PHP5 (FastCGI) And MySQL On Linux Mint 12 / Ubuntu 11.10
By: Raj Last Updated: January 16, 2016 0 Comments lighttpd, linuxmint, linuxmint 12, mysql, php, php cgi, ubuntu, ubuntu 11.10, web server

Security, speed, compliance, and flexibility — all of these describe lighttpd (pron. lighty) which is rapidly redefining efficiency of a web server; as it is designed and optimized for high performance environments. With a small memory footprint compared to other web-servers, effective management of the cpu-load, and advanced feature set (FastCGI, SCGI, Auth, Output-Compression, URL-Rewriting and many more) lighttpd is the perfect solution for every server that is suffering load problems. And best of all it’s Open Source licensed under the revised BSD license.

Here i will explain you the installation of Lighttd with PHP and MySQL on Linux Mint 12.
Installing Lighttpd:

To start off we will install Lighttpd.

Type following Command on the Terminal and then press enter.

raj@geeksite~/$ sudo apt-get install lighttpd

Start the Lighttpd by using the following command.

raj@geeksite~/$ sudo /etc/init.d/lighttpd restart

Testing Lighttpd:

To make sure everything installed correctly we will now test Lighttpd to ensure it is working properly. Open up any web browser and then enter the following into the web address:

http://127.0.0.1/index.lighttpd.html  or  http://your.ip.addr.ess/index.lighttpd.html

You should see the Lighttpd Placeholder page, lighttpd’s default document root is /var/www/ on Ubuntu / Linux Mint; the configuration file is /etc/lighttpd/lighttpd.conf and additional configurations are stored in the /etc/lighttpd/conf.available/ directory.

that is found on this page:

http://www.itzgeek.com/how-tos/linux/ubuntu-how-tos/how-to-install-lighttpd-with-php5-and-mysql-on-linux-mint-12-ubuntu-11-10.html

RE: newbie FAMNoExists - Added by signmeuptoo about 2 months ago

Ok, wait a minute, I did something that is getting me somewhere where I wasn't before, as far as I recall:

I gedited the lightppd.conf file with the server.document.root to /home/myusername/public_html once I made that empty directory that it appears I had deleted and I chmoded it 755 and now I get the apache2 start page when I go to 127.0.0.1.

So evidently indeed my sever document root path was a problem with how lighttpd was installed OR what I messed up when I was doing my LAMP install efforts before now.

So my question is where SHOULD public_html directory go in my distro and what should be in it? I put index.html in it from a copy I had in /var/www/html that was a backup from stuff I had tried back when I had trouble with setting up LAMP which I had never got working.

RE: newbie FAMNoExists - Added by signmeuptoo about 2 months ago

ok, so I am getting somewhere, but now I see where my problem was before now with LAMP install, on this page:

http://www.itzgeek.com/how-tos/linux/ubuntu-how-tos/how-to-install-lighttpd-with-php5-and-mysql-on-linux-mint-12-ubuntu-11-10.html

This part of the tutorial:

Next is to install the MySQL server and client, both are available in Linux Mint repository; just issue the following command to install it.

raj@geeksite~/$ sudo apt-get install mysql-server mysql-client php5-mysql

only the part up until php5-mysql installs, as it appears php5-mysql is obsolete or unsupported in my version of mint, as per this as we see here:

"sudo apt-get install mysql-server mysql-client php5-mysql
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package php5-mysql is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'php5-mysql' has no installation candidate
"

I cannot figure out what to put there in its place. Now I realize where I had problems before now. I went through lots of tutorials and never found the solution.

RE: newbie FAMNoExists - Added by gstrauss about 2 months ago

$ sudo apt-get install php7.0 php7.0-mysql

    (1-10/10)