Project

General

Profile

[Solved] Lighttpd on LEDE - server.stream-response-body = 2 ignored

Added by rob@blue-wave.net 3 months ago

I have a php script and want to display on the browser as the script progresses.
Setting server.stream-response-body = 2 seems to have no effect, lighttpd just keep buffering until the script completes.
The same script on uhttpd works fine (~but takes very much longer).
On embedded devices this is an issue as memory consumption rockets as data is buffered leading to LEDE terminating lighttpd in extreme circumstances.
LEDE 17.01.2 lighttpd 1.4.45-3

Am I missing something?


Replies (2)

RE: Lighttpd on LEDE - server.stream-response-body = 2 ignored - Added by rob@blue-wave.net 3 months ago

Solved:
I must add my configuration is for https only.
Both server.stream-response-body = 2 and ssl.read-ahead = "disable" are required.
Now working perfectly.
Perhaps this should be added into the documentation ;)

RE: Lighttpd on LEDE - server.stream-response-body = 2 ignored - Added by gstrauss 3 months ago

It was added to the documentation 5 days before your post above. See Server_stream-request-bodyDetails

Where else do you suggest it be documented? The sample lighttpd.conf may be different in different distributions and will not be made to look like apache.conf tome. lighttpd.conf is often very short and simple for most people, and should remain so.

    (1-2/2)