Project

General

Profile

Feature #2030

Don't log (request.c.535) no uri specified -> 400 (by default)

Added by Olaf-van-der-Spek about 7 years ago. Updated about 7 years ago.

Status:
Fixed
Priority:
Normal
Assignee:
-
Category:
core
Target version:
Start date:
2009-07-12
Due date:
% Done:

100%

Missing in 1.5.x:

Description

Could you disable logging of this error by default?

(request.c.535) no uri specified -> 400 (by default)

Associated revisions

Revision 2583 (diff)
Added by stbuehler about 7 years ago

Show "no uri specified -> 400" error only when "debug.log-request-header-on-error" is enabled (fixes #2030)

Revision 1b2cc3bb (diff)
Added by stbuehler about 7 years ago

Show "no uri specified -> 400" error only when "debug.log-request-header-on-error" is enabled (fixes #2030)

git-svn-id: svn://svn.lighttpd.net/lighttpd/branches/lighttpd-1.4.x@2583 152afb58-edef-0310-8abb-c4023f1b3aa9

History

#1 Updated by Olaf-van-der-Spek about 7 years ago

  • Target version changed from 1.4.22 to 1.4.24

It's a bit unclear what version means. Seems it is target version, not version in which the bug was found.

#2 Updated by stbuehler about 7 years ago

It may be a little bit unexpected, but i think the meaning if "Target version" is clear :)

And it is on my "TODO" list to patch redmine that you cannot set target version to a released version :)

#3 Updated by stbuehler about 7 years ago

  • Status changed from New to Fixed
  • % Done changed from 0 to 100

Applied in changeset r2583.

#4 Updated by Olaf-van-der-Spek about 7 years ago

stbuehler wrote:

It may be a little bit unexpected, but i think the meaning if "Target version" is clear :)

Target version is clear indeed, but here it just says version. Maybe that's just the Dutch translation again?

Also available in: Atom