Project

General

Profile

Errors with vhosts on lighttpd relating to html files not being picked up and/or a subdomain not working. PLEASE HELP!

Added by cooldude13233 about 10 years ago

Hello,

I seem to be having some problems with setting vhosts on lighttpd, I have a url rewrite structure setup for 2 wordpress websites, and they work ok, thing is that within those 2 wordpress website directories, I cannot look at any html files in there, and the way the wordpress url rewrite structures I have setup is completely breaking another subdomain for webfiles I have, and within that subdomain, a url redirect structure is not working, pasted bellow this paragraph is a pastebin of the whole vhosts I have setup for my lighttpd setup, I hope someone can look at this and try to get a way to fix this up for me because I tried all I can to fix it, so if someone can help me fix this problem, it will be greatly appreciated. Thanks!

http://pastebin.com/EB2HcyVu


Replies (2)

RE: Errors with vhosts on lighttpd relating to html files not being picked up and/or a subdomain not working. PLEASE HELP! - Added by cooldude13233 about 10 years ago

UPDATE:

Ironic enough, from the new pastebin link I posted bellow, if I pass " url.rewrite-repeat-if-not-file " into where the wordpress rewrite structures, I do see a flash file appearing on that subdomain that is breaking from that " url.rewrite-final " and/or " url.rewrite " that I passed into the wordpress url rewrite, and those html files inside the wordpress directory can be visible, but ONLY a blank white screen. Can someone help me nonetheless? Thanks!

http://pastebin.com/iWu3JXZj

RE: Errors with vhosts on lighttpd relating to html files not being picked up and/or a subdomain not working. PLEASE HELP! - Added by cooldude13233 about 10 years ago

UPDATE:

I have got it to work, it seems that " url.rewrite-repeat-if-file " in the wordpress url rewrite structures i have set is a valid config option, and it seems to work.

    (1-2/2)