Project

General

Profile

why can't disable mmap..

Added by bwalker@musings.com almost 8 years ago

I am porting lighttpd over to an embedded system running uCLinux. This system doesn't have an MMU so I'm trying to disable use of mmap.

When I run configure I always see the following:

checking for mmap... yes

And that does not seem correct if I try to disable it.

I'm running the latest stable release of lighttpd.

Here is the confgure line that I used:

./configure --host arm-uclinuxeabi -without-pcre --without-zlib --without-bzip2 --disable-ipv6 --disable-lfs --enable-static --enable-mmap=no

I've attached the gory details of configure output if you are interested.

Thanks for any help you can provide.

-brad walker

configure-out.txt (12.7 KB) configure-out.txt Output from configure

Replies (3)

RE: why can't disable mmap.. - Added by darix almost 8 years ago

well the configure check for mmap works. so your libc/kernel headers seem to offer it.

RE: why can't disable mmap.. - Added by stbuehler almost 8 years ago

lighttpd relies in many places on the "fact" that dereferencing NULL (with a small offset) results in SIGSEGV. Running without MMU breaks that...

Also uCLinux relies on mmap() for memory allocation, so it certainly has to be present.

RE: why can't disable mmap.. - Added by bwalker@musings.com almost 8 years ago

I'm aware that uCLinux relies on mmap() for memory allocation.

My question really boils down to the configure script testing for mmap() when I tell it not to.

That doesn't seem correct me regardless of if the system provides it or not.

    (1-3/3)