Project

General

Profile

[Solved] Readonly file system listing in web interface issue

Added by jiby over 1 year ago

I am using web server as LIGHTTPD....database as sqlite3....And php..

I have installed the os in the flash memmory of nanopi..and sqlit database in sd card
I made my flash memmory of nanopi as readonly(in fstab).

while content listing from database to web page it is showing only limed amount of data( for example...in a webpage i am given to list 55 records.but beacuse of this readonly file system it is listing 19 records and no pagination.)

How to make readonly filesystem without affecting above


Replies (4)

RE: Readonly file system listing in web interface issue - Added by gstrauss over 1 year ago

Please see the documentation. Docs_ConfigurationOptions

You might need to set server.upload-dirs = ( "/var/tmp" ) to someplace writable, such as /tmp, or some scratch space on the SD card.

Maybe share your lighttpd.conf?

RE: Readonly file system listing in web interface issue - Added by jiby over 1 year ago

I have changed server.upload-dirs = ( "/var/tmp" )...but after changing this lighttpd is failed to load..

my lighttpd.conf file is

server.modules = (
        "mod_access",
        "mod_alias",
        "mod_compress",
        "mod_redirect",
)

server.document-root        = "/var/www/html" 
#server.upload-dirs          = ( "/var/cache/lighttpd/uploads" )
server.upload-dirs            ( "/home/sd/" )
server.errorlog             = "/var/log/lighttpd/error.log" 
#server.errorlog              = "/home/sd/error_light.log" 
server.pid-file             = "/var/run/lighttpd.pid" 
server.username             = "www-data" 
server.groupname            = "www-data" 
server.port                 = 80
alias.url = ( "/waves/" => "/home/sd/waves/" )
index-file.names            = ( "index.htm", "index.php", "index.html", "index.lighttpd.html" )
url.access-deny             = ( "~", ".inc" )
static-file.exclude-extensions = ( ".php", ".pl", ".fcgi" )
dir-listing.activate = "enable" 
compress.cache-dir          = "/var/cache/lighttpd/compress/" 
#compress.cache-dir           = "/var/tmp/cache/lighttpd/compress/" 
compress.filetype           = ( "application/javascript", "text/css", "text/html", "text/plain" )

cache.bases = ("/tmp/lighttpd")
cache.enable = "enable" 
cache.support-queries = "enable" 
cache.debug = "enable" 
cache.dynamic-mode = "enable" 

# default listening port for IPv6 falls back to the IPv4 port
include_shell "/usr/share/lighttpd/use-ipv6.pl " + server.port
include_shell "/usr/share/lighttpd/create-mime.assign.pl" 
include_shell "/usr/share/lighttpd/include-conf-enabled.pl" 

RE: Readonly file system listing in web interface issue - Added by jiby over 1 year ago

sorry...that was my mistake... I forgot to put "=" in "server.upload-dirs ( "/home/sd/" )"

    (1-4/4)