Project

General

Profile

Bug #2235

Only use -std=gnu99 flag when appropriate.

Added by brad@comstyle.com almost 7 years ago. Updated almost 3 years ago.

Status:
Fixed
Priority:
Normal
Assignee:
-
Target version:
Start date:
2010-07-06
Due date:
% Done:

100%


Description

Currently the autoconf script tries to use the -std=gnu99 flag all of the time if using GCC but this breaks compilation with gcc 2.95. The attached patches fixes the autoconf script.

patch-configure_ac.patch View (570 Bytes) brad@comstyle.com, 2010-07-06 22:16

Associated revisions

Revision 4b14ad8f (diff)
Added by Stefan Bühler almost 3 years ago

[autobuild] Check whether compiler supports wanted CFLAGS (fixes #2235)

From: Stefan Bühler <>

git-svn-id: svn://svn.lighttpd.net/spawn-fcgi/trunk@65 4a9f3682-ca7b-49a8-9a55-ba4640e46f83

Revision 65 (diff)
Added by stbuehler almost 3 years ago

[autobuild] Check whether compiler supports wanted CFLAGS (fixes #2235)

From: Stefan Bühler <>

History

#1 Updated by stbuehler almost 3 years ago

  • Status changed from New to Fixed
  • % Done changed from 0 to 100

Applied in changeset r65.

Also available in: Atom