Project

General

Profile

FastCGI mod error on start - spawning gw failed

Added by Wido about 2 months ago

2021-06-09 22:05:27: server.c.1513) server started (lighttpd/1.4.59) 
2021-06-09 22:05:27: gw_backend.c.475) unlink /tmp/script.sock-0 after connect failed: Connection refused 
2021-06-09 22:05:27: gw_backend.c.325) child exited: 127 unix:/tmp/script.sock-0 
2021-06-09 22:05:27: gw_backend.c.601) gw-backend failed to start: /var/www/html/script.fcgi 
2021-06-09 22:05:27: gw_backend.c.603) If you're trying to run your app as a FastCGI backend, make sure you're using the FastCGI-enabled version. If this is PHP on Gentoo, add 'fastcgi' to the USE flags. If this is PHP, try removing the bytecode caches for now and try again. 
2021-06-09 22:05:27: gw_backend.c.1655) [ERROR]: spawning gw failed. 
2021-06-09 22:05:27: server.c.1517) Configuration of plugins failed. Going down.

Hello!
I am using lighttpd/1.4.59 (ssl) on Ubuntu 21.04. My conf file contains:

server.modules += (
"mod_dirlisting",
"mod_staticfile",
"mod_fastcgi" 
)
fastcgi.debug = 1
fastcgi.balance = "least-connection" 
fastcgi.server = (
"/hello" => ((
"bin-path" => "/var/www/html/script.fcgi",
"socket" => "/tmp/script.sock",
"check-local" => "disable",
"max-procs" => 1,
))
)

If I run ./script.fcgi I get html markup in terminal. How to fix it? Thank you.


    (1-1/1)