Project

General

Profile

Actions

Bug #1484

closed

"stream decoder failed" error in mod_proxy_core.c

Added by Anonymous over 16 years ago. Updated almost 8 years ago.

Status:
Obsolete
Priority:
Normal
Category:
mod_proxy_core
Target version:
ASK QUESTIONS IN Forums:

Description

This ticket corresponds to the forum message at:
http://forum.lighttpd.net/topic/30435#new

My lighttpd version is 1.5.0-r1992 on CentOS 5, being used as a load balancer to a backend Tomcat instance. I get intermittent errors in my error.log of the form:


mod_proxy_core.c.864: (error) stream decoder failed.
mod_proxy_core.c.2424: (trace) state: 6 (error)
plugin.c.389: (trace) -- plugins_call_...: plugin 'mod_proxy_core' returns 5
connections.c.1289: (trace) (error)
connections.c.830: (trace) got FDEVENT_OUT for state 10, calling the job-handler, let's see what happens

when I am serving up some of my larger Javascript files. This seems to happen whether or not I'm using the http or ajp13 protocols, and no matter the balancing strategy.

I've attached an appropriate segment of the strace from this error... let me know if any more of the trace is needed.

-- brian.albers


Files

lighttpd.trace (255 KB) lighttpd.trace Anonymous, 2007-12-11 03:33
Actions #1

Updated by gstrauss almost 8 years ago

  • Description updated (diff)
  • Assignee deleted (jan)
  • Missing in 1.5.x set to Yes
Actions #2

Updated by gstrauss almost 8 years ago

  • Status changed from New to Obsolete
Actions

Also available in: Atom