Project

General

Profile

Bug #1542

upload large files

Added by Anonymous over 11 years ago. Updated about 3 years ago.

Status:
Fixed
Priority:
Normal
Assignee:
-
Category:
core
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:
Missing in 1.5.x:

Description

Hi.

I am using lighttpd 1.5.0 1922 with mod_uploadprogress and php fcgi.

Uploading 10mb files works fine, but 100mb+ files sometimes dont work.

My post action is a php script, which redirects to another page after handling the uploaded file (expected status: 302).
But if I upload a large file (100mb and more) I sometimes see status 200 in accesslog (php script not executed) and the browser (ff2 / ie7) retries to upload the file.
After 2 or 3 attempts I get 302 and the file is handled by the php script.

Any idea? I tried to debug, but I dont know what I need to looking for.

Thank You!

History

#1

Updated by tx over 11 years ago

fix your php.ini to allow large posts and large upload :)

#2

Updated by Anonymous over 11 years ago

php.ini settings:

upload_max_filesize = 300M
post_max_size = 350M
max_execution_time = 30
max_input_time = 60
memory_limit = 400M

Sometimes upload of 100mb files works. Upload fails on 10mb files too, if I upload a big file simultaneously.

#3

Updated by Anonymous over 11 years ago

The PHP script is executed after all. But the $_FILE array contains following error code:

UPLOAD_ERR_PARTIAL, Value: 3; The uploaded file was only partially uploaded.

So Firefox 2 uploads the file tree times:
1. error
2. error
3. ok

Any idea?

#4

Updated by Anonymous over 11 years ago

IE7 tries it only one time and get a timeout. (accesslog still 200 -)(

#5

Updated by Anonymous over 11 years ago

server.max-keep-alive-requests = 0

fixed it. Thank you for your help!

Ticket can be closed.

#6

Updated by gstrauss about 3 years ago

  • Description updated (diff)
  • Status changed from New to Fixed
  • Assignee deleted (jan)

fixed per above note

Also available in: Atom