Project

General

Profile

Actions

Bug #2307

closed

Support for libev >= 4.0

Added by kapouer about 10 years ago. Updated over 9 years ago.

Status:
Fixed
Priority:
Normal
Target version:
-

Description

Hi,
multiwatch doesn't compile against libev in some cases where
libev has been compiled with EV_MULTIPLICITY=0 (in debian, with
libev4, because libev3 did not hide ev_loop even in that case).

Configure checks for ev_loop in ev, which is unavailable, and
making it check for ev_default_loop fixes the issue.
So it works in both cases, it is just a matter of how it checks
the availability of libev.

Actions #1

Updated by stbuehler over 9 years ago

  • Status changed from New to Fixed
  • % Done changed from 0 to 100
Actions

Also available in: Atom