Project

General

Profile

Actions

Bug #2335

closed

1.4.29 doesn't compile on Centos6 due to disabled EC

Added by lvs over 10 years ago. Updated over 10 years ago.

Status:
Fixed
Priority:
Normal
Category:
-
Target version:
ASK QUESTIONS IN Forums:

Description

The forum issue reported here (http://redmine.lighttpd.net/boards/2/topics/4335) prevents the compilation of the latest lighttpd on Centos6. The reason is a missing check for OPENSSL_NO_ECDH in network.c which gets removed from openssl in Fedora/RHEL/CentOS. Attached is a patch to incorporate that check.


Files

Actions #1

Updated by stbuehler over 10 years ago

  • Status changed from New to Fixed

Fixed in r2802

Actions #2

Updated by stbuehler over 10 years ago

  • Target version set to 1.4.30
Actions

Also available in: Atom