Project

General

Profile

Actions

Bug #3082

closed

issues with server side includes (SSI)

Added by mtnman 24 days ago. Updated 24 days ago.

Status:
Invalid
Priority:
Normal
Category:
mod_ssi
Target version:
ASK QUESTIONS IN Forums:
No

Description

We have developed a product that uses a Beaglebone Black running Debian 8 and using Lighttpd as our webserver. It has worked very well for quite a while. We’re at the point where we want to update to Debian 10. We have built a new unit using Debian 10, installed lighttpd, but are now having a problem with server side includes (SSI) with this configuration. Attached is a small screenshot of a webpage showing the issue.

As you can see, rather than showing the result of executing the command, it’s showing the actual command. This leads us to believe that server side includes are not working – not activated – within lighttpd.

We do include mod_ssi under server.modules in the lighttpd.conf file we’re using (the lighttpd.conf file is very similar to the one we used in the original Debian 8 installation that worked with no issues).

The full lighttpd.conf can be found here:
https://pastebin.com/BhFEfbzQ

On our original installation, we were on Debian 8.9 and Lighttpd 1.4.35. On the new install, we are using a Debian 10.3 IOT image (stripped down) with lighttpd 1.4.53. SSI just worked on the earlier installation and I never had to do anything special. The logs at /var/log/lighttpd don’t show any issues.

I’ve done lots of online reading but nothing I’ve tried so far has resolved the issue.
I’m hoping someone can show me what I’m doing wrong. Thanks for any help!


Files

lighttpd.png (11.9 KB) lighttpd.png mtnman, 2021-05-26 16:06
Actions #1

Updated by mtnman 24 days ago

My apologies, I think I posted this in the wrong place. It's not a bug, rather I'm looking for help in resolving an issue.

Actions #2

Updated by gstrauss 24 days ago

  • Status changed from New to Invalid

As you noticed, this is the lighttpd issue tracker for issues in lighttpd, not user configuration questions.
If you have a question, please post in the Forum. See the Forums tab near the top of this page. There is a forum named "Support".

Actions #3

Updated by gstrauss 24 days ago

BTW, if you are (finally) migrating from lighttpd 1.4.35 -- which is over 7 years old and has known security issues which are not patched in ancient Debian releases -- please consider using lighttpd 1.4.59 which is available in buster-backports for Debian 10

For troubleshooting your config, see DebugVariables

Actions

Also available in: Atom