Project

General

Profile

Bug #35

https directory redirects to non-https

Added by Anonymous over 14 years ago. Updated over 12 years ago.

Status:
Fixed
Priority:
Normal
Assignee:
-
Category:
core
Target version:
-
Start date:
Due date:
% Done:

0%

Estimated time:
Missing in 1.5.x:

Description

Still broken in 1.3.11.

https://x.y.com/dir

becomes

http://x.y.com/dir/

-- brett

Associated revisions

Revision 5492063f (diff)
Added by gstrauss over 3 years ago

[core] set REDIRECT_STATUS to error_handler_saved_status (fixes #1828)

set REDIRECT_STATUS to con->error_handler_saved_status in dynamic
handlers for PHP compiled with --force-redirect. Set to "200"
if (0 con->error_handler_saved_status)
(mod_cgi, mod_fastcgi, mod_scgi, mod_ssi)

FYI: setting REDIRECT_STATUS in con->environment allows access and
manipulation by mod_magnet.

x-ref:
"REDIRECT_STATUS 200 on 404 redirect"
https://redmine.lighttpd.net/issues/1828

github: closes #35

History

#1

Updated by jan over 14 years ago

  • Status changed from New to Assigned

Can't reproduce in .11.

Please enable

debug.log-request-headers = "enable"
debug.log-response-headers = "enable"
debug.log-request-handling = "enable"

and attach it to the bug-report

#2

Updated by Anonymous over 14 years ago

isn't this fixed at bottom of changeset r50?

-- Elan Ruusamäe <glen

#3

Updated by jan over 14 years ago

No, that is only for debug output.

#4

Updated by jan over 14 years ago

  • Status changed from Assigned to Fixed
  • Resolution set to fixed

Also available in: Atom