Bug #624


Lighttpd hangs or fails to start through SSH

Added by Anonymous almost 15 years ago. Updated almost 13 years ago.

Target version:


I believe my problem is related to this debian bug:

No idea whether that patch would work for me as I am using a custom restart script written in Ruby. I have tried forking a new thread to start lighttpd and then detaching it but that hasn't worked.

Basically, when starting lighty through SSH it tends to hang. I have been deploying a Rails app with Capistrano. In this circumstance sometimes Capistrano will not hang, but instead the process will start successfully and then immediately stop. Either way I tend to have to intervene when deploying which is of course not ideal.

The development server I've been using is Ubuntu Breezy, and the deployment server is FC1. I have the problem on both.

Let me know if I can provide any more information.


-- turnip


Updated by moo almost 15 years ago

that means lighttpd may not detach correctly (in case u don't use -D)
workaround: lighttpd -f conf </dev/null >/dev/null 2>&1.

i'll keep this ticket open..


Updated by Anonymous over 13 years ago

I just came across this exact problem, but on FreeBSD (on textdrive). I was using vlad, not capistrano, so odd ssh issues are out of the question as well. I can confirm that moo's workaround indeed works. It would be nice if lighttpd detached properly.

-- ryand-ruby


Updated by stbuehler almost 13 years ago

  • Status changed from New to Fixed
  • Resolution set to fixed

I cannot reproduce it in current version, so i guess this was fixed.

Please give more details if you disagree (attach config)


Updated by stbuehler almost 13 years ago

Darix told me i am wrong, so i looked at it again; it seems that (at least) debian has a workaround in the ssh server for this, so i had to use lsof to see lighty having the files still open.

I hope i fixed that problems in r2163 now.

Also available in: Atom