Bug #2377

Crash when I try to visit website over https

Added by CyberCr33p almost 4 years ago. Updated almost 4 years ago.

Status:InvalidStart date:2011-12-23
Priority:NormalDue date:
Assignee:-% Done:


Target version:-
Missing in 1.5.x:No


I run Lighttpd 1.4.30 with FreeBSD and when I try to visit a website over https lighttpd crash (signal 11)

Here is the backtrace:

#0  0x08056423 in network_init ()
#1  0x280fac94 in ssl23_accept () from /usr/lib/libssl.so.5
#2  0x280fb086 in ssl23_read () from /usr/lib/libssl.so.5
#3  0x2810e548 in SSL_read () from /usr/lib/libssl.so.5
#4  0x080525a3 in http_response_write_header ()
#5  0x08053d87 in connection_state_machine ()
#6  0x08054e40 in network_register_fdevents ()
#7  0x0804ee79 in main ()


#1 Updated by CyberCr33p almost 4 years ago

  • Target version set to 1.4.31

Looks like the issue is solved with using this patch:


#2 Updated by nitrox almost 4 years ago

  • Status changed from New to Invalid
  • Target version deleted (1.4.31)

Also available in: Atom