Project

General

Profile

Bug #653

mod_cgi doesn't work with server.bind set to unix domain socket

Added by Anonymous over 10 years ago. Updated about 8 years ago.

Status:
Fixed
Priority:
Normal
Assignee:
-
Category:
core
Target version:
Start date:
Due date:
% Done:

0%

Missing in 1.5.x:

Description

If i bind lighty to a unix domain socket, cgi scripts no longer work. Rather than displaying the output of the cgi, the browser attempts to download a zero-length copy of the cgi file.

Static html and mod_fastcgi continue to work, which leads me to believe there's a bug in mod_cgi.

Test configuration:
Pound proxy 1.0.5 to Lighttpd 1.4.11 via unix domain socket.

I had initially thought that perhaps Pound was the culprit, since I had just added Unix domain socket support to Pound the night before. However, the main Pound developer independently added the same support and both implementations get the same result. Also, the fact that mod_fastcgi and static pages continue to work point to a probable bug in mod_cgi.

-- cliff

Associated revisions

Revision 90bfe20b (diff)
Added by stbuehler about 8 years ago

Fix mod_cgi segfault when bound to unix domain socket (#653)

git-svn-id: svn://svn.lighttpd.net/lighttpd/branches/lighttpd-1.4.x@2316 152afb58-edef-0310-8abb-c4023f1b3aa9

History

#1 Updated by Anonymous almost 10 years ago

I'm having the same problem (with the same result: a zero-length "copy" of the script is downloaded by the browser) with lighttpd 1.4.11, but without binding it to a socket or something similar. Not much to report here, as the logs only tell me that the cgi process probably died.

-- jannis

#2 Updated by stbuehler about 8 years ago

  • Status changed from New to Fixed
  • Resolution set to fixed

Fixed in r2316

Also available in: Atom