Project

General

Profile

[Solved] Monsta FTP and buffering download

Added by wrkilu about 1 month ago

Hi,
I have configuration: Centos 7 + Lighttpd + PHP-FPM. And I installed as a site Monsta FTP application (this is in fact FTP server via website). And when I click download some file on this site I see Lighttpd first download that file to /var/tmp/ as a lots of small files and when finish I get this window with saving file to disk. How to configure Lighttpd to he don'r buffer this downloading but let immediately/directly download file from FTP server ?

Regards


Replies (6)

RE: Monsta FTP and buffering download - Added by gstrauss about 1 month ago

How to configure Lighttpd to he don'r buffer this downloading but let immediately/directly download file from FTP server ?

short answer: you should try to find an answer in the documentation before you post a question.

server.stream-request-body
server.stream-response-body

RE: [Solved] Monsta FTP and buffering download - Added by wrkilu about 1 month ago

I doesn't work.

I've set both these parameters to 1 or to 2 (in lighttpd.conf in Basic section) and nothing. When I click test.dat file for download first php-fpm downloading file to /tmp and then he is serving it for download. Hmmm... so maybe its a php-fpm's fault ?

RE: [Solved] Monsta FTP and buffering download - Added by gstrauss about 1 month ago

You're using CentOS 7 and the problem is more likely that you have no idea how old and out-of-date is the software you are running.

RE: [Solved] Monsta FTP and buffering download - Added by wrkilu about 1 month ago

So
lighttpd-1.4.54-1.el7.x86_64
lighttpd-fastcgi-1.4.54-1.el7.x86_64
are really so old and thats why it doesn't work ?

RE: [Solved] Monsta FTP and buffering download - Added by gstrauss about 1 month ago

I doesn't work.

You have accurately described your effort.

RE: [Solved] Monsta FTP and buffering download - Added by wrkilu about 1 month ago

I see server.stream-request-body and server.stream-response-body options appeared in release 1.4.40. So you aren't right that my Lighttpd v. 1.4.54 on Centos 7 is too old.

    (1-6/6)