Project

General

Profile

[Solved] mod_fastcgi Tests are failing.

Added by rvr about 2 months ago

  • The php fastcgi service(started with php-cgi.exe -b 127.0.0.1:9123) is abruptly terminating when navigating .php pages in the lighttpd server.
  • Running "make check" also shows the mod-fastcgi tests are failing. Please find the logs below. Attached ./configure logs as well. Thank you.

OS: Windows 10.
Built with cygwin(uname -r gives 3.3.5-341.x86_64)

Log:

preparing infrastructure PASS: prepare.sh
./core-condition.t .. ok
./mod-fastcgi.t ..... 2/24 #
  1. status failed: expected '200', got '500'
  1. Failed test 'valid request'
  2. at ./mod-fastcgi.t line 63.
    ./mod-fastcgi.t ..... 9/24 #
  3. status failed: expected '200', got '401'
  1. Failed test '$_SERVER["REMOTE_USER"]'
  2. at ./mod-fastcgi.t line 91. #
  3. status failed: expected '200', got '401'
    ./mod-fastcgi.t ..... 10/24
  4. Failed test '$_SERVER["AUTH_TYPE"]'
  5. at ./mod-fastcgi.t line 100.
  6. Looks like you failed 3 tests of 24.
    ./mod-fastcgi.t ..... Dubious, test returned 3 (wstat 768, 0x300)
    Failed 3/24 subtests
    ./mod-scgi.t ........ ok
    ./request.t ......... 102/178 #
  7. status failed: expected '200', got '401'
    ./request.t ......... 104/178
  8. Failed test 'Basic-Auth: Valid Auth-token - htpasswd (des)'
  9. at ./request.t line 1116.
    ./request.t ......... 105/178 #
  10. status failed: expected '200', got '401'
  1. Failed test 'Basic-Auth: Valid Auth-token - htpasswd (des) (lowercase)'
  2. at ./request.t line 1125.
    ./request.t ......... 151/178 # Looks like you failed 2 tests of 178.
    ./request.t ......... Dubious, test returned 2 (wstat 512, 0x200)
    Failed 2/178 subtests
    (less 1 skipped subtest: 175 okay)

Test Summary Report
-------------------
./mod-fastcgi.t (Wstat: 768 (exited 3) Tests: 24 Failed: 3)
Failed tests: 6, 9-10
Non-zero exit status: 3
./request.t (Wstat: 512 (exited 2) Tests: 178 Failed: 2)
Failed tests: 104-105
Non-zero exit status: 2
Files=4, Tests=238, 17 wallclock secs ( 0.02 usr 0.08 sys + 0.78 cusr 1.88 csys = 2.75 CPU)
Result: FAIL
Failed 2/4 test programs. 5/238 subtests failed.
FAIL: run-tests.pl
cleaning up PASS: cleanup.sh ========================================================================
1 of 3 tests failed
Please report to https://redmine.lighttpd.net/projects/lighttpd/boards/2 ========================================================================
make3: * [Makefile:661: check-TESTS] Error 1
make2:
[Makefile:812: check-am] Error 2
make1:
[Makefile:568: check-recursive] Error 1
make: *
[Makefile:474: check-recursive] Error 1

configure_log.txt (13.4 KB) configure_log.txt Configure Options
make_check_log.txt (2.86 KB) make_check_log.txt Output of test runs

Replies (3)

RE: mod_fastcgi Tests are failing. - Added by gstrauss about 2 months ago

Please verify that you are running the latest updates from cygwin. Run cygwin setup and update your cygwin environment.

lighttpd 1.4.66 built and passed tests for me on an up-to-date Windows 10 (old laptop) and up-to-date cygwin as of a little more than a week ago.

(My Windows 10 build machine has since borked itself on Windows Update and now refuses to boot or recover, so lighttpd 1.4.66 packages for Windows might be delayed until mid-Sep due to my travels.)

RE: mod_fastcgi Tests are failing. - Added by rvr about 2 months ago

Thank you! Let me try with a fresh cygwin installation then.

RE: [Solved] mod_fastcgi Tests are failing. - Added by gstrauss 22 days ago

lighttpd 1.4.66 is now available to install as a package under cygwin.

    (1-3/3)