[Solved] Sticking 403 problem

Added by roelvdh 2 months ago

I just installed lighttpd on an existing CentOS box running other services as well. Starting with the 5 min Config tutorial

server.document-root = "/var/www/servers/pages/" 

server.port = 3000

mimetype.assign = (
  ".html" => "text/html", 
  ".txt" => "text/plain",
  ".jpg" => "image/jpeg",
  ".png" => "image/png" 

and running lighttpd from this config I immediately got a 403 response in my browser. I temporarily changed permissions of /var/www (all) to 777 and expected to see my index file /var/www/servers/pages/index.html showing up but I only get 403 errors. As there are other services running on the computer I assume there is a conflict somewhere but I have no clue where to start solving that. The lighttpd log only shows that the service is running.

Replies (2)

RE: Sticking 403 problem - Added by gstrauss 2 months ago

Please try

I'll update the example.

RE: Sticking 403 problem - Added by gstrauss 27 days ago

You must enable mod_indexfile to have lighttpd serve index.html when you request