Project

General

Profile

[Solved] Accessing files on NTFS

Added by jmoeller almost 6 years ago

I have a raspberry pi 3 running Raspian and I just installed lighthttpd. It is working. I need to mount an external hard drive for additional content. I created a symbolic link /var/www/html/hd linked to the drive. When I attempt to access anything on the HD via lighttpd, I get 403 Forbidden.

I am not too familiar with linux but usually able to struggle through. The only thing I found to try was to add "server.follow-symlink="enable" to the config file, which I did. Restarted of course. But still no joy? Any idea what I am missing? (I did not mount the drive myself, I simply connected to the box and it was auto mounted).

I appreciate any advice.

Thanks,
Jonathan


Replies (4)

RE: Accessing files on NTFS - Added by gstrauss almost 6 years ago

I am going to guess that you want to get a directory listing of the contents of the hd. server.follow-symlink = "enable" is the default, and you probably need to add dir-listing.activate = "enable" to enable directory listings.

RE: Accessing files on NTFS - Added by jmoeller almost 6 years ago

That is good to know and I will make that change but I am just trying to bring up a simple index.html. The URL that I am using is http://raspberrypi/HD/index.html. Still 403 - Forbidden. Any other suggestions?

RE: Accessing files on NTFS - Added by gstrauss almost 6 years ago

1) check lighttpd error log
2) su to lighttpd user (or whichever user you run webserver as) and try to access the file

RE: [Solved] Accessing files on NTFS - Added by gstrauss over 5 years ago

If none of the above worked, and you're still trying to serve index files, you need to enable serving index files
server.indexfiles = ( "index.html" )

Also, you need to check the permissions applied on the automounted drive. The lighttpd web server needs access permissions to be able to serve files.

    (1-4/4)