Project

General

Profile

[Solved] Cross Compile with ptxdist failed for 1.4.59 (1.4.58 works)

Added by Agossi about 2 months ago

I wanted to use the latest lighttpd 1.4.59 with ptxdist 2015 but it failed to cross compile.
The 1.4.58 worked without any problem.

I figured out if I am using the old "ax_prog_cc_for_build.m4" and rerun autoconf to generate the configure file it solves the problem, but this is not a good idea for further updates.

I get the following error running the build for 1.4.59:

./configure: line 5253: test: =: unary operator expected
checking whether gcc accepts -g... yes
checking for gcc option to accept ISO C89... none needed
checking whether gcc understands -c and -o together... yes
checking dependency style of gcc... gcc3
checking whether the C compiler works... yes
checking for C compiler default output file name... a.out
checking for suffix of executables... 
checking whether we are cross compiling... no
checking for suffix of object files... o
checking how to run the C preprocessor... gcc

configure: error: C preprocessor "gcc" fails sanity check

Any suggestion what the issue is in 1.4.59?


    (1-2/2)