Project

General

Profile

Bug #1030

mod_webdav and sqlite

Added by Anonymous almost 13 years ago. Updated over 11 years ago.

Status:
Invalid
Priority:
High
Assignee:
-
Category:
mod_webdav
Target version:
Start date:
Due date:
% Done:

0%

Estimated time:
Missing in 1.5.x:

Description

i am running lighttpd 1.4.13 on a mipsel platform
using uclibc 0.9.28.1 and kernel 2.4.20

everything works fine except when i enable
webdav with lock.

it fails when sqlite db file is created.
strace attached.


Files

error.txt (17.3 KB) error.txt -- chengann Anonymous, 2007-02-13 04:22
strace.txt (41.7 KB) strace.txt Anonymous, 2008-03-29 11:37
gdb.txt (1.58 KB) gdb.txt Anonymous, 2008-03-29 11:38
#1

Updated by jan almost 13 years ago

  • Status changed from New to Assigned

can you provide backtrace with gdb and attach it ?

#2

Updated by Anonymous over 12 years ago

so sorry. my embedded platform has limited resources.
installing gdb will be very difficult.

i have since tried lightty 1.5. r1811.
error message is clearer now:
(mod_webdav.c.232) can't open transaction: file is encrypted or is not a database

it does seem like a sqlite problem.

#3

Updated by Anonymous almost 12 years ago

Hi,

I have the same problem. can not activate mod webdav with sqlite. same error message.

my system is:
Hardware:
Processor : XScale-IXP42x Family rev 2 (v5l)
BogoMIPS : 266.24
Features : swp half fastmult edsp
CPU implementer : 0x69
CPU architecture: 5TE
CPU variant : 0x0
CPU part : 0x41f
CPU revision : 2
Cache type : undefined 5
Cache clean : undefined 5
Cache lockdown : undefined 5
Cache format : Harvard
I size : 32768
I assoc : 32
I line length : 32
I sets : 32
D size : 32768
D assoc : 32
D line length : 32
D sets : 32

Hardware : Linksys NSLU2
Revision : 0000
Serial : 0000000000000000

Software:
cat /etc/debian_version
4.0
dpkg -l|grep light
ii lighttpd 1.4.13-4etch6 A fast webserver with minimal memory footpri
ii lighttpd-doc 1.4.13-4etch6 Documentation for lighttpd
ii lighttpd-mod-webdav 1.4.13-4etch6 WebDAV module for lighttpd

/usr/sbin/lighttpd -t -f /etc/lighttpd/lighttpd.conf
Syntax OK

/usr/sbin/lighttpd -D -f /etc/lighttpd/lighttpd.conf
2008-03-29 12:39:32: (mod_webdav.c.227) can't open transaction: unable to open database file
2008-03-29 12:39:32: (server.c.849) Configuration of plugins failed. Going down.

I have installed strace and gdb on this powerfule machine :)
I will attach the both files to this ticket, but I think "something" went wrong with my gdb ... please take a look on it.

would like to hear from you.

cheers

-- hijacka

#4

Updated by stbuehler over 11 years ago

  • Status changed from Assigned to Fixed
  • Resolution set to invalid

I guess lighty didn't have the permission to open/create the sqlite database:


open("/var/run/lighttpd/lighttpd.webdav_lock.db-journal", O_RDWR|O_CREAT|O_EXCL|O_LARGEFILE, 0644) = -1 EACCES (Permission denied)
#5

Updated by stbuehler over 11 years ago

  • Status changed from Fixed to Invalid

Also available in: Atom