Project

General

Profile

Bug #2127

compile error with glib

Added by liming over 9 years ago. Updated over 9 years ago.

Status:
Fixed
Priority:
Normal
Assignee:
-
Category:
build_autotools
Target version:
Start date:
2009-12-29
Due date:
% Done:

100%

Estimated time:
Missing in 1.5.x:
No

Description

hi, I compiled lighttpd 1.5.0 svn r2698, and got a error message: ".../src/server.c:990: undefined reference to `g_atomic_int_set' ", It seems because the glib version is older than 2.10.

however, I think adding a parameter "./configure --with-glib=..." is helpful. Do you have any other better ideas?

Associated revisions

Revision 2701 (diff)
Added by stbuehler over 9 years ago

Require at least glib 2.10.0 for g_atomic_int_set (fixes #2127)

History

#1

Updated by nitrox over 9 years ago

  • Status changed from New to Invalid

I think this is not a bug, if you have problems compiling, please use the support forum. If this is a feature request, please mark it as that.

#2

Updated by liming over 9 years ago

  • Status changed from Invalid to Reopened

No, I don't agree with you.

In configure.ac:

454 PKG_CHECK_MODULES(GTHREAD, gthread-2.0 >= 2.4.0, [
455 AC_DEFINE([HAVE_GTHREAD], [1], [libglib])
456 AC_DEFINE([HAVE_GLIB_H], [1], [glib.h])
457 ])

Line 454 is wrong. It should be "PKG_CHECK_MODULES(GTHREAD, gthread-2.0 >= 2.10.0, [", because gthread is just one of the components in glib. Only when glib version is equal or newer than 2.10, lighttpd is succeed to be compiled. right?

#3

Updated by icy over 9 years ago

  • Category changed from core to build_autotools

Correct. For whatever reason g_atomic_int_set got only into gthread in version 2.10. All the other g_atomic_* were introduced in 2.4 which is a bit weird but well...
Yep we should require 2.10

#4

Updated by stbuehler over 9 years ago

  • Status changed from Reopened to Fixed
  • % Done changed from 0 to 100

Applied in changeset r2701.

Also available in: Atom