Project

General

Profile

Problems with trailing 0 in URI

Added by mdurrant about 6 years ago

I've been having a weird problem with 1.4.28.
Any URL that ends with a trailing 0 causes lighttpd to crash completely, alternating between a 500 and 503 error every few refreshes.

For example:
example.com/index.php (works fine)
example.com/index.php/news/672 (works fine)
example.com/index.php/news/6720 (crashes)

2011-03-01 17:47:41: (mod_fastcgi.c.2906) establishing connection failed: Connection refused socket: tcp:127.0.0.1:9999
2011-03-01 17:47:41: (mod_fastcgi.c.2912) backend is overloaded; we'll disable it for 1 seconds and send the request to another backend instead: reconnects: 0 load: 1
2011-03-01 17:47:43: (mod_fastcgi.c.3597) all handlers for /0? on 0 are down.
2011-03-01 17:47:43: (mod_fastcgi.c.2854) fcgi-server re-enabled: tcp:127.0.0.1:9999

I am using lighttpd with the only modules enabled that aren't on by default being mod_evasive, mod_rewrite, fastcgi and simple_vhost. I have confirmed that it is a mod_fastcgi issue, but I'm not sure how to troubleshoot it.


Replies (6)

RE: Problems with trailing 0 in URI - Added by Olaf-van-der-Spek about 6 years ago

That's not a crash of Lighttpd.
Looks like a crash of PHP.

RE: Problems with trailing 0 in URI - Added by fl0 about 6 years ago

I've got exactly the same problem with drupal (6.20) lua for clean urls and php53 on Scientific Linux (5.5) 32Bit.
Everything's working fine except for urls containing a trailing "0" (Zero)

Here is the error.log


2011-04-03 22:26:50: (mod_fastcgi.c.2906) establishing connection failed: Connection refused socket: tcp:127.0.0.1:9999 
2011-04-03 22:26:50: (mod_fastcgi.c.2912) backend is overloaded; we'll disable it for 1 seconds and send the request to another backend instead: reconnects: 0 load: 1 
2011-04-03 22:26:52: (mod_fastcgi.c.2854) fcgi-server re-enabled: tcp:127.0.0.1:9999 
2011-04-03 22:26:53: (mod_fastcgi.c.2906) establishing connection failed: Connection refused socket: tcp:127.0.0.1:9999 
2011-04-03 22:26:53: (mod_fastcgi.c.2912) backend is overloaded; we'll disable it for 1 seconds and send the request to another backend instead: reconnects: 0 load: 1 
2011-04-03 22:26:54: (mod_fastcgi.c.3597) all handlers for /node/300? on 0 are down. 
2011-04-03 22:26:55: (mod_fastcgi.c.2854) fcgi-server re-enabled: tcp:127.0.0.1:9999

This is very strange, maybe this is an php error ... nevertheless ... maybe so can help us out here?

RE: Problems with trailing 0 in URI - Added by less about 6 years ago

We do have the same problem here for:

- php v5.2.14-0.7.22.1
- lighttpd v1.4.28-2.5
- SLES 11 SP1 i586

2011-05-16 10:16:05: (mod_fastcgi.c.2906) establishing connection failed: Connection refused socket: tcp:127.0.0.1:9999
2011-05-16 10:16:05: (mod_fastcgi.c.2912) backend is overloaded; we'll disable it for 1 seconds and send the request to another backend instead: reconnects: 0 load: 1
2011-05-16 10:16:06: (mod_fastcgi.c.3597) all handlers for /cmp3.php/0? on 0 are down.
2011-05-16 10:16:07: (mod_fastcgi.c.2854) fcgi-server re-enabled: tcp:127.0.0.1:9999
2011-05-16 10:16:50: (mod_fastcgi.c.2906) establishing connection failed: Connection refused socket: tcp:127.0.0.1:9999
2011-05-16 10:16:50: (mod_fastcgi.c.2912) backend is overloaded; we'll disable it for 1 seconds and send the request to another backend instead: reconnects: 0 load: 1
2011-05-16 10:16:52: (mod_fastcgi.c.2854) fcgi-server re-enabled: tcp:127.0.0.1:9999

any ideas?

RE: Problems with trailing 0 in URI - Added by stbuehler almost 6 years ago

  • just enabling example configs is never a good idea. understand what they do, and use what you need.
  • somehow the configs resulted in a fastcgi.server with extension key "0" (so it triggers on all urls with trailing "0"); this is the case if you omit the extension ".php" => like fastcgi.server = ( ( ... ) ) - if someone can provide an example where this happens in other cases i'd like to see the config.

RE: Problems with trailing 0 in URI - Added by nhantam over 5 years ago

I have same problem

my application testing

My URL:
[[http://www.nghenghiepviet.com/tim-viec/nganh-nghe-Ban-hang/0]]
// run error 503 - Service Not Available

but URL: [[http://www.nghenghiepviet.com/tim-viec/nganh-nghe-Ban-hang/1]]
//run OK

Could you help me. How do I fix problem ?

Thanks you very much

RE: Problems with trailing 0 in URI - Added by Adewra about 5 years ago

I had a similar problem running Lighttpd, PHP and CodeIgniter with url rewrites like everyone else.

If you look in your conf.d folder, and open up fastcgi.conf, youll probably have a line

fastcgi.server = ( ".php" =>...

Well, this says if the URL ends .php, then carry out these instructions ....

So we bluff it adding the line

fastcgi.map-extensions = ( "" => ".php" )

N.B.
This will map all extensions to .php, this includes your CSS, JS files etc.
On my server, I host these files on a different server, and didn't have any problems, but if you host it all on the same server, the browser wont render your files properly.

    (1-6/6)