Project

General

Profile

[Solved] Phpmyadmin 404 - Not Found error

Added by leegold over 7 years ago

Hi,

Every time I try to access localhost/phpmyadmin or localhost/phpmyadmin/index.php I get a 404 - Not Found. But, http://localhost/testphp.php works OK. I had Apache installed in the past but removed it and recently installed Lighttpd. I'm using Lubuntu 10.10 a flavor of Ubuntu and using my laptop (localhost)as a testbed to learn. I have tried restarting Lighttpd after each change to the conf file. Please tell me if more info is needed to help fix it and I will post it. Here is my lighttpd.conf. Thanks for the help:

# Debian lighttpd configuration file
#

############ Options you really have to take care of ####################

## modules to load
server.modules = (
            "mod_alias",
            "mod_compress",
#           "mod_rewrite",
#           "mod_redirect",
#           "mod_usertrack",
#           "mod_expire",
            "mod_flv_streaming",
#           "mod_evasive" 
            "mod_fastcgi" 
)

## a static document-root, for virtual-hosting take look at the
## server.virtual-* options
server.document-root       = "/var/www/" 

## where to upload files to, purged daily.
server.upload-dirs = ( "/var/cache/lighttpd/uploads" )

## where to send error-messages to
server.errorlog            = "/var/log/lighttpd/error.log" 

## files to check for if .../ is requested
index-file.names           = ( "index.php", "index.html",
                               "index.htm", "default.htm",
                               "index.lighttpd.html" )

## Use the "Content-Type" extended attribute to obtain mime type if possible
# mimetype.use-xattr = "enable" 

##
# which extensions should not be handle via static-file transfer
#
# .php, .pl, .fcgi are most often handled by mod_fastcgi or mod_cgi
static-file.exclude-extensions = ( ".php", ".pl", ".fcgi" )

######### Options that are good to be but not neccesary to be changed #######

## Use ipv6 only if available. (disabled for while, check #560837)
#include_shell "/usr/share/lighttpd/use-ipv6.pl" 

## bind to port (default: 80)
# server.port               = 81

## bind to localhost only (default: all interfaces)
## server.bind                = "localhost" 

## error-handler for status 404
#server.error-handler-404  = "/error-handler.html" 
#server.error-handler-404  = "/error-handler.php" 

## to help the rc.scripts
server.pid-file            = "/var/run/lighttpd.pid" 

##
## Format: <errorfile-prefix><status>.html
## -> ..../status-404.html for 'File not found'
#server.errorfile-prefix    = "/var/www/" 

## virtual directory listings
dir-listing.encoding        = "utf-8" 
server.dir-listing          = "enable" 

### only root can use these options
#
# chroot() to directory (default: no chroot() )
#server.chroot            = "/" 

## change uid to <uid> (default: don't change)
server.username            = "www-data" 

## change gid to <gid> (default: don't change)
server.groupname           = "www-data" 

#### compress module
compress.cache-dir          = "/var/cache/lighttpd/compress/" 
compress.filetype           = ("text/plain", "text/html", "application/x-javascript", "text/css")

#### url handling modules (rewrite, redirect, access)
# url.rewrite                 = ( "^/$"             => "/server-status" )
# url.redirect                = ( "^/wishlist/(.+)" => "http://www.123.org/$1" )

#### expire module
# expire.url                  = ( "/buggy/" => "access 2 hours", "/asdhas/" => "access plus 1 seconds 2 minutes")

#### external configuration files
## mimetype mapping
include_shell "/usr/share/lighttpd/create-mime.assign.pl" 

## load enabled configuration files,
## read /etc/lighttpd/conf-available/README first
include_shell "/usr/share/lighttpd/include-conf-enabled.pl" 

## added later by goldtech

fastcgi.server = ( ".php" => ((
                     "bin-path" => "/usr/bin/php-cgi",
                     "socket" => "/tmp/php.socket" 
                 )))

flv-streaming.extensions = ( ".flv" )

alias.url = ( "/phpmyadmin/” => “/usr/share/phpmyadmin/")

------end of file

Replies (4)

RE: Phpmyadmin 404 - Not Found error - Solved - Added by leegold over 7 years ago

$ sudo dpkg-reconfigure phpmyadmin

there are checkboxes - it's obvious.

And remove the line I added:

alias.url = ( "/phpmyadmin/" => "/usr/share/phpmyadmin/")

from the conf file.

Fixed it.

RE: Phpmyadmin 404 - Not Found error - Added by golden3 about 2 years ago

How about the Same scenario in Centos 6.7 , let me know the exact conclusion.

RE: Phpmyadmin 404 - Not Found error - Added by gstrauss about 2 years ago

golden3: you posted to a topic over 5 years old, which already details what leegold did to resolve it.
Did you try what was suggested? If you'd like assistance, please provide (a lot) more information on the problem you are having, what you tried to do to solve it, and what happened for each thing that you tried.

RE: Phpmyadmin 404 - Not Found error - Added by leegold about 2 years ago

The 404 can still happen, a better fix is:

alias.url = ("/phpmyadmin" => "/usr/share/phpmyadmin")

and then mywebsite/phpmyadmin works OK.

    (1-4/4)