Project

General

Profile

[Solved] Curious message on startup with version 1.4.63

Added by flynn 10 months ago

With version 1.4.63 I get the following messages on startup:

(configfile.c.426) Warning: mod_auth should be listed in server.modules before dynamic backends such as mod_scgi
(configfile.c.426) Warning: mod_auth should be listed in server.modules before dynamic backends such as mod_wstunnel
(configfile.c.426) Warning: mod_auth should be listed in server.modules before dynamic backends such as mod_proxy

But I do not load/use mod_auth, lighttpd -f /etc/lighttpd/lighttpd.conf -p | grep mod_auth is empty.

Did I miss smething, is there an autoload feature?


Replies (2)

RE: Curious message on startup with version 1.4.63 - Added by gstrauss 10 months ago

That message was added in lighttpd 1.4.62, but it is a bug that the trace is issued when no mod_auth modules are loaded.
commit 8b10f94c

I don't think that I want to do another release so soon after 1.4.63 just to fix the trace, but I am planning a release in early Jan to remove deprecated modules, and this will be fixed then, too.

--- a/src/configfile.c
+++ b/src/configfile.c
@@ -369,6 +369,7 @@ static void config_compat_module_load (server *srv) {
     int contains_mod_auth      = 0;
     int prepend_mod_auth       = 0;
     int prepend_mod_vhostdb    = 0;
+    const char *dyn_name = NULL;

     for (uint32_t i = 0; i < srv->srvconf.modules->used; ++i) {
         buffer *m = &((data_string *)srv->srvconf.modules->data[i])->value;
@@ -390,8 +391,15 @@ static void config_compat_module_load (server *srv) {
         else if (buffer_eq_slen(m, CONST_STR_LEN("mod_wolfssl")))
             append_mod_openssl = 0;
         else if (0 == strncmp(m->ptr, "mod_auth", sizeof("mod_auth")-1)) {
-            if (buffer_eq_slen(m, CONST_STR_LEN("mod_auth")))
-                contains_mod_auth = 1;
+            if (buffer_eq_slen(m, CONST_STR_LEN("mod_auth"))) {
+                if (!contains_mod_auth) {
+                    contains_mod_auth = 1;
+                    if (dyn_name)
+                        log_error(srv->errh, __FILE__, __LINE__,
+                          "Warning: mod_auth should be listed in server.modules" 
+                          " before dynamic backends such as %s", dyn_name);
+                }
+            }
             else if (!contains_mod_auth)
                 prepend_mod_auth = 1;

@@ -422,11 +430,7 @@ static void config_compat_module_load (server *srv) {
                                          sizeof("mod_sockproxy")-1)
                  || 0 == strncmp(m->ptr, "mod_wstunnel",
                                          sizeof("mod_wstunnel")-1)) {
-            if (!contains_mod_auth) {
-                log_error(srv->errh, __FILE__, __LINE__,
-                  "Warning: mod_auth should be listed in server.modules before " 
-                  "dynamic backends such as %s", m->ptr);
-            }
+            dyn_name = m->ptr;
         }
     }

Did I miss smething, is there an autoload feature?

There is a limited autoload feature for backward compatibility. It can be disabled with server.compat-module-load = "disable". By default, lighttpd loads mod_indexfile, mod_dirlisting, and mod_staticfile, though mod_indexfile and mod_dirlisting additionally need to be configured to be enabled. When I split some modules, such as mod_authn_file from mod_auth, I added some autoload for backward compatibility.

RE: Curious message on startup with version 1.4.63 - Added by flynn 10 months ago

gstrauss wrote in RE: Curious message on startup with version 1.4.63:

That message was added in lighttpd 1.4.62, but it is a bug that the trace is issued when no mod_auth modules are loaded.
commit 8b10f94c

I don't think that I want to do another release so soon after 1.4.63 just to fix the trace, but I am planning a release in early Jan to remove deprecated modules, and this will be fixed then, too.

I agree, this is why I did not open a ticket ...

    (1-2/2)