Project

General

Profile

[Solved] Set-Up Rectification

Added by Richard-Aus about 2 months ago

Hi there,
I have been using Lighttpd without issues and today added PHP. I created a file: /etc/lighttpd/conf-available/example.com.conf with the contents below.

$HTTP["host"] == "www.temp.com" { server.document-root = "/var/www/html/" server.errorlog = "/var/log/lighttpd/temp.com-error.log" }

I changed example.com to temp.com. So when I enter temp.com it takes me to the PHP splash page, so it is working. I cannot now work out how to undo this. I have rerun parts of the setup, deleted the install, fresh reinstall but despite not using temp.com again it won't go away (even in private browsing).

What simple setting am I missing? Thanks!

Richard.


Replies (6)

RE: Set-Up Rectification - Added by gstrauss about 2 months ago

Make sure that you have restarted the lighttpd server after making configuration changes.

How to get support

RE: Set-Up Rectification - Added by Richard-Aus about 2 months ago

THanks for the response, the sever was restarted (sudo systemctl restart lighttpd) and also rebooted the rasbperrypi.

RE: Set-Up Rectification - Added by gstrauss about 2 months ago

How to get support

You probably have not read the above link and followed the instructions, or else you should have shared the results.

RE: Set-Up Rectification - Added by Richard-Aus about 2 months ago

Apollogies for not providing all information and for the delay in my response as I have been offshore:

1. Operating system: Raspbian GNU/Linux 11 (bullseye)
2. lighttpd/1.4.59 (ssl)
3. See attached - Config 1.txt and Config 2.txt
4. Chromium (Raspberry Pi default)

I have removed all packages, rebooted, reinstalled and skipped the "example.com.conf" step with the same result. I am certain the PHP server is working as I can run PHP script. I would like to resolve why the temp.com has "stuck" and routes to localhost:80.

Thank you in advance.

R.

RE: Set-Up Rectification - Added by gstrauss about 2 months ago

I changed example.com to temp.com. So when I enter temp.com it takes me to the PHP splash page, so it is working. I cannot now work out how to undo this. I have rerun parts of the setup, deleted the install, fresh reinstall but despite not using temp.com again it won't go away (even in private browsing).

What simple setting am I missing? Thanks!

I have removed all packages, rebooted, reinstalled and skipped the "example.com.conf" step with the same result. I am certain the PHP server is working as I can run PHP script. I would like to resolve why the temp.com has "stuck" and routes to localhost:80.

This does not appear to be related to lighttpd, and is more likely a caching issue in your browser, perhaps due to response headers provided by your PHP. Clear your browser caches and/or try a different client, e.g. command line curl

RE: Set-Up Rectification - Added by Richard-Aus about 2 months ago

Thanks - I had cleared the chache/browsing hisotry initally (and used in-provate browsing too) and the same issue occured (Thursday). Today (Sunday) I cleared the browsing hisotry and now all ij OK. Quite odd. Not sure why/how but it is fixed.

Many thanks.

    (1-6/6)