Project

General

Profile

Bug #2713

Issue with enabling Lighttpd module "mod_h264_streaming"

Added by wizztechs over 4 years ago. Updated over 4 years ago.

Status:
Invalid
Priority:
Low
Category:
-
Target version:
-
ASK QUESTIONS IN Forums:

Description

Hello,

We have an issue while enabling "mod_h264_streaming" in Lighttpd configuration. When added this module in server.modules list in the lighttpd configuration, we are not able to start the service with the following error:

--

root@s [/usr/local/src/lighttpd-1.4.39]# systemctl status lighttpd.service
● lighttpd.service - SYSV: Lightning fast webserver with light system requirements
Loaded: loaded (/etc/rc.d/init.d/lighttpd)
Active: active (running) since Thu 2016-02-04 10:40:14 CET; 2min 20s ago
Docs: man:systemd-sysv-generator(8)
Process: 14960 ExecStart=/etc/rc.d/init.d/lighttpd start (code=exited, status=0/SUCCESS)
Main PID: 14964 (lighttpd)
CGroup: /system.slice/lighttpd.service
└─14964 /usr/sbin/lighttpd -f /etc/lighttpd/lighttpd.conf

Feb 04 10:40:14 s.yerkio.com systemd1: Starting SYSV: Lightning fast webserver with light system requirements...
Feb 04 10:40:14 s.yerkio.com lighttpd14960: Starting lighttpd: 2016-02-04 10:40:14: (network.c.283) warning: please use server.use-ipv6 only for hostnames, not without server.bind / empty...6ONLY changes
Feb 04 10:40:14 s.yerkio.com lighttpd14960: [ OK ]
Feb 04 10:40:14 s.yerkio.com systemd1: Started SYSV: Lightning fast webserver with light system requirements.
Hint: Some lines were ellipsized, use l to show in full.
-

Its a cPanel server with Centos 7. Apache is running on port 80 and lihttpd is running at port 81. lihttpd is used only for streaming purposes.

We have tried the versions 1.4.39 and 1.50 (from source code compile installation)and both returns the same issue.

Any idea regarding this error?

Thank you.

#1

Updated by stbuehler over 4 years ago

  • Category deleted (mod_flv_streaming)
  • Status changed from New to Invalid
  • Assignee deleted (darix)
  • Priority changed from High to Low
  • Target version deleted (1.4.x)

mod_h264_streaming is a 3rd-party module, not supported, and probably wasn't updated to match the latest abi changes.

Don't use 3rd-party modules which were compiled against a different lighttpd version.

#2

Updated by wizztechs over 4 years ago

Hi,

We have tried to install different versions of Lighttpd with "mod_h264_streaming" module and none of them allowed to start the service when the module added in the server.modules list in the lighttpd configuration. Does this module support/compatible with any of the available versions of Lighttpd?

Thank you.

#3

Updated by patrickdk over 4 years ago

How would anyone here know? the mod_h264_streaming module was note designed, coded, or compiled by anyone here. You will have to talk to the people you got mod_h264_streaming from.

Also available in: Atom